Apple und sein Support

Gestern war ja einiges los über Berlin. Für eine halbe Stunde war es dunkel wie vor dem Weltuntergang. Wasser ergoss sich über unsere Dächer, Donner ertönte und Blitze schossen herunter.
Ich habe noch nie ein Problem bei Gewitter mit elektronischen Geräten gehabt. Deswegen bleiben die auch immer an. Das muss es ab und schließlich hat man ja den Blitzableiter.

Diesmal saß ich vor meinem Macbook und schrieb an der Bachelorarbeit. Als plötzlich die Nacht zum Tag wurde und wohl ein Blitz direkt in unser Haus einschlug. Ein kurzes Zischen und mein Rechner war aus. Ich hatte Todesangst! Meine Arbeit, mein Macbook.
Nach einigen Minuten konnte ich wieder klar denken und steckte meinen Akku in das Macbook. Es schien normal zu starten. Puh. Doch mit dem Netzteil am Gerät wurde der Akku nicht geladen und die kleine LED am Stecker leuchtete nur leicht Grün. Wohl defekt.

Sofort die Apple Supportnummer mit dem letzten Akkusaft herausgesucht und angerufen. Alles geprüft, der Hotliner empfahl mir zu einem authorisierten Händler zu fahren. Davon gäbe es in Berlin ja sieben Stück und da würde der Austausch schneller gehen, als wenn Apple mir direkt ein Austauschgerät senden würde. Toll, dachte ich. Dann kann ich gleich am Samstag hin und das Ding austauschen. Danach wäre alles wie vorher.

Heute also zu Gravis am Ernst-Reuter-Platz. 50 Minuten Fahrt mit den Öffentlichen. Mein Macbook hatte ich daheim gelassen. Schließlich hatte der Hotliner all meine Daten aufgenommen.
Punkt Nummer eins: Ohne ihr Macbook können wir da leider nichts machen. Mit Netzteil und Rechner wir ein Code generiert, den Apple für den Support benötigt. Ich dachte, ich raste aus. Ich stand also bei Gravis nach fast einer Stunde Fahrt und zu pünktlichem Aufstehen am Schalter und der Typ wollte/konnte mir nicht helfen, weil ich mein Macbook nicht mit hatte?
Punkt zwei: Als ich ihn düster ansah, ging er flugs mit dem Netzteil nach hinten und verschwand für eine Weile. Er kam mit dem Code wieder und erzählte mir, dass es bis Mitte nächster Woche dauern könnte ein neues Netzteil von Apple zu bekommen. Sowas haben wir nicht auf Lager. Wie, was?! Hier stehen zig Rechner rum und ihr könnt mir kein neues Netzteil geben?

Also zu dem anderen authorisierten Händler um die Ecke. Dort konnte man mir gar nicht helfen, weil der Techniker am Wochenende nicht da sei. Kann ich also davon ausgehen, dass ihr nicht in der Lage seid mir einen Austausch zu geben, weil euer Techniker nicht da ist?

Zurück zu Gravis. Mich am Service-Point angemeldet, damit jeder meinen Namen groß auf dem Bildschirm über den Schaltern sehen kann. Kann ich einfach ein neues Netzteil kaufen und das wird dann als Austausch verrechnet? Nein, das geht nicht. Apple nutzt unterschiedliche Seriennummern für neue und ausgetauschte Geräte.
Jetzt warte ich also bis mich nächste Woche jemand anruft und sagt, dass ich mein Austauschgerät abholen kann. Wieder zwei Stunden für die Hin- und Rückfahrt. Solange kann ich nicht richtig arbeiten.

Danke Apple!

Anhang

Liebes Apple,
warum könnt ihr nicht einfach neben euren zig Support-Codes und Seriennummern ein System benutzen, dass jedem Hotliner gleich sagt, wieviel Austauschteile bei euren tollen “authorisierten” Händlern zur Verfügung stehen? Dann könnte ich mich gleich dafür entscheiden, dass mir der Austausch zugesendet wird.
Das wäre wirklich mal Support!

ct-Bot: Aufbau beendet

Nachdem ich eine Weile auf einen Ersatz für den defekten Liniensensor warten musste, konnte ich ihn vor einiger Zeit endlich ausgetauschen. Dazu habe ich mir eine Entlötsaugpumpe besorgt. Mit der ist es möglich flüssiges Lot aus den Lötstellen zu saugen. Genial, nicht wahr?

Die vier Lötstellen des Sensors waren jedoch trotzdem ziemlich schwer zu lösen und ich brauchte mehrere Anläufe. Nun ist der Austauschsensor eingelötet und funktioniert auf den ersten Blick wie er soll.

Die nächste Aufgabe stellte der Einbau der Maussensorplatine dar. Die Linse für den Maussensor sollte mit zwei Platinenstreifen an die Maussensorplatine gedrückt werden und mit zwei Schrauben befestigt werden. Dadurch hätte die Maussensorplatine jedoch um einige Millimeter höher unter dem Bot angebracht werden müssen. Im Vorfeld habe ich gelesen, dass das die Leistung des Maussensor negativ beeinträchtigt. Leicht nachvollziehbar, wenn eine optische Maus zum Vergleich herangezogen wird. Hält man sie einige Millimeter über der Unterlage, bewegt sich der Mauszeiger nur nur sprunghaft oder gar nicht.

Aus oben genanntem Grund habe ich nach Alternativen gesucht. Was ich im Haushalt finden konnte, war reißfestes Tape. Wie auf einem der Bilder zu erkennen ist, habe ich die Linse für den Maussensor mit diesem Tape anstatt der zwei Platinenstreifen befestigt. Dadurch konnte ich die Maussensorplatine um einige Millimeter tiefer unter dem Bot befestigen und hoffe im Ergebnis eine bessere Leistung zu erhalten.

Die zwei Sensorplatinen, an denen die Radsensoren und die Abgrundsensoren befestigt sind, wurden mit schwarzer Pappe zu den Aluträgern hin isoliert. Sie sollen Kurzschlüsse und damit auch verfälschte Werte der Sensoren vermeiden.

Nach dem Aufbau ist mir noch ein Fehler meinerseits aufgefallen. Das Batteriefach habe ich falsch verkabelt. Ein zweiter Versuch zeigte Wirkung und der Bot läuft jetzt auch mit Akkus.

P1010710.JPGP1010701.JPGP1010709.JPGP1010704.JPGP1010711.JPGP1010712.JPGP1010708.JPGP1010705.JPGP1010707.JPGP1010698.JPGP1010713.JPGP1010706.JPG

Was jetzt noch fehlt ist Zeit für den zweiten Teil: die Programmierung. Dazu muss aber zuerst einmal meine Abschlussarbeit für mein Studium fertig geschrieben sein.